aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2016-07-26 13:27:37 +0200
committerChristian Tismer <tismer@stackless.com>2016-07-26 11:55:20 +0000
commite7580ec31b94b7a2f600774bf9c7f1ff971ee5e9 (patch)
tree4912481f35bd9f6e7edc7b84a45158f26bb10134 /setup.py
parent9d696bbcbcff4269feb64fbc4453888d4a4ef8de (diff)
setup.py: Fix branches
- Change the examples to the dev branch - Introduce an optional 3rd parameter to the submodules hash pointing to the directory and use that to switch the wiki module to the master branch. This makes it possible to run commands like git submodule foreach git pull which did not work previously due to the wiki submodule being in a headless state. Change-Id: Ib90f68f73e3401431fd2dce90f02ed75095a5429 Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 9c5a3f7e3..0034e7170 100644
--- a/setup.py
+++ b/setup.py
@@ -45,7 +45,8 @@ submodules = {
["shiboken2", "dev"],
["pyside2", "dev"],
["pyside2-tools", "dev"],
- ["pyside2-examples", "master"],
+ ["pyside2-examples", "dev"],
+ ["wiki", "master", ".."],
],
}
old_submodules = {
@@ -284,7 +285,10 @@ if os.path.isdir(".git") and not OPTION_IGNOREGIT and not OPTION_ONLYPACKAGE:
module_name = m[0]
module_version = m[1]
print("Checking out submodule %s to branch %s" % (module_name, module_version))
- module_dir = os.path.join(submodules_dir, module_name)
+ module_dir = ''
+ if len(m) > 2:
+ module_dir = m[2]
+ module_dir = os.path.join(submodules_dir, module_dir, module_name)
os.chdir(module_dir)
git_checkout_cmd = ["git", "checkout", module_version]
if run_process(git_checkout_cmd) != 0: