aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRoman Lacko <backup.rlacko@gmail.com>2013-04-15 13:07:41 +0200
committerRoman Lacko <backup.rlacko@gmail.com>2013-04-15 13:07:41 +0200
commit6565281a5ed53375ee739a54efb7bcfec90640dc (patch)
tree9ce35b158d8fabb80767b117f6f778823cb96ffa /setup.py
parent580d76113c50fb82469cda373c7a63e94b6279bd (diff)
Option --version can not be used together with option --ignore-git
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 3 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 506eec771..2b40f527d 100644
--- a/setup.py
+++ b/setup.py
@@ -136,6 +136,9 @@ script_dir = os.getcwd()
# Change package version
if OPTION_VERSION:
+ if OPTION_IGNOREGIT:
+ print("Option --version can not be used together with option --ignore-git")
+ sys.exit(1)
if not os.path.isdir(".git"):
print("Option --version is available only when pyside-setup was cloned from git repository")
sys.exit(1)