aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRoman Lacko <backup.rlacko@gmail.com>2014-03-31 11:57:53 +0200
committerRoman Lacko <backup.rlacko@gmail.com>2014-03-31 11:57:53 +0200
commit28fa103063cd633ae9654d3a5d3395d9bdbdfb2c (patch)
treee13a9134aa6deafc632e9b4434b6e42b662582cd /setup.py
parent588e3baf0d41915895253acf21f991af66e4b9d3 (diff)
parenta8f1cf676125f314c99645fb27c707bd678db491 (diff)
Merge pull request #22 from bjoernthiel/master
Enable debug build for Python 3 as well
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 4 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 2fdc513b9..5a53de3d7 100644
--- a/setup.py
+++ b/setup.py
@@ -580,9 +580,10 @@ class pyside_build(_build):
cmake_cmd.append("-DPYTHON_LIBRARY=%s" % self.py_library)
if self.build_type.lower() == 'debug':
cmake_cmd.append("-DPYTHON_DEBUG_LIBRARY=%s" % self.py_library)
- if sys.platform == "win32" and self.build_type.lower() == 'debug':
- cmake_cmd.append("-DCMAKE_DEBUG_POSTFIX=_d")
-
+
+ if sys.platform == 'win32':
+ cmake_cmd.append("-DCMAKE_DEBUG_POSTFIX=_d")
+
if extension.lower() == "shiboken":
cmake_cmd.append("-DCMAKE_INSTALL_RPATH_USE_LINK_PATH=yes")
if sys.version_info[0] > 2: