aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2016-04-29 15:41:05 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2016-05-02 06:44:09 +0000
commit36d73601718252f5066e9b488247f9c9ed5f1285 (patch)
tree6d0928bd62c6aadedafdd602974fc398ecb100b3 /setup.py
parent750506e98778657a4550f9f94387527ab4caf00b (diff)
Switch submodule repositories.
Clone submodules from code.qt.io and adapt branches. Change-Id: Iecf128ca00c4eb25e5450db8630e42e9307bd7cc Reviewed-by: Alexandru Croitor <alexandru.croitor@theqtcompany.com> Reviewed-by: Christian Tismer <tismer@stackless.com> Reviewed-by: Gabriel de Dietrich <gabriel.dedietrich@qt.io> Reviewed-by: Alex Blasche <alexander.blasche@theqtcompany.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 4 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index e308c3b20..b7cd3fb9c 100644
--- a/setup.py
+++ b/setup.py
@@ -30,9 +30,9 @@ __version__ = "2.0.0.dev0"
submodules = {
'2.0.0.dev0': [
- ["shiboken2", "master"],
- ["pyside2", "master"],
- ["pyside2-tools", "master"],
+ ["shiboken2", "dev"],
+ ["pyside2", "dev"],
+ ["pyside2-tools", "dev"],
["pyside2-examples", "master"],
],
}
@@ -257,10 +257,7 @@ if os.path.isdir(".git") and not OPTION_IGNOREGIT and not OPTION_ONLYPACKAGE:
git_update_cmd = ["git", "submodule", "update", "--init"]
if run_process(git_update_cmd) != 0:
raise DistutilsSetupError("Failed to initialize the git submodules")
- git_pull_cmd = ["git", "submodule", "foreach", "git", "fetch", "origin"]
- if run_process(git_pull_cmd) != 0:
- raise DistutilsSetupError("Failed to initialize the git submodules")
- git_pull_cmd = ["git", "submodule", "foreach", "git", "pull", "origin", "master"]
+ git_pull_cmd = ["git", "submodule", "foreach", "git", "fetch", "--all"]
if run_process(git_pull_cmd) != 0:
raise DistutilsSetupError("Failed to initialize the git submodules")
submodules_dir = os.path.join(script_dir, "sources")