aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRoman Lacko <backup.rlacko@gmail.com>2013-02-18 16:31:14 +0100
committerRoman Lacko <backup.rlacko@gmail.com>2013-02-18 16:31:14 +0100
commit945b5abe8655b390ec430b1300ecfbb58b86eacf (patch)
tree77ce008392313c614bb9b627725ec15fd4c9d103 /setup.py
parent02d32fab93b18d67ebcf7d307ac12767eb4eb35a (diff)
Added --ignore-git option
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 49f2b1783..afdea9b8e 100644
--- a/setup.py
+++ b/setup.py
@@ -93,6 +93,7 @@ OPTION_STANDALONE = has_option("standalone")
OPTION_VERSION = option_value("version")
OPTION_LISTVERSIONS = has_option("list-versions")
OPTION_MAKESPEC = option_value("make-spec")
+OPTION_IGNOREGIT = has_option("ignore-git")
if OPTION_QMAKE is None:
OPTION_QMAKE = find_executable("qmake")
@@ -145,7 +146,7 @@ Use --list-versions option to get list of available versions""" % OPTION_VERSION
__version__ = OPTION_VERSION
# Initialize, pull and checkout submodules
-if os.path.isdir(".git"):
+if os.path.isdir(".git") and not OPTION_IGNOREGIT:
print("Initializing submodules for PySide version %s" % __version__)
git_update_cmd = ["git", "submodule", "update", "--init"]
if run_process(git_update_cmd) != 0: