aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorRoman Lacko <backup.rlacko@gmail.com>2014-05-14 00:30:43 +0200
committerRoman Lacko <backup.rlacko@gmail.com>2014-05-14 00:30:43 +0200
commite63edfc9d4a1fd9703c9c3ec02ee460d24109b60 (patch)
tree3ba2514b7268106d2e238d8d1abe2a86a0e751bd /setup.py
parenta9a0f27bb22a8a96f26358e49cc08f5046b350f3 (diff)
Refactoring docs/index.rst into separate rst files
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 11 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 19f65675c..d6e9bbe2e 100644
--- a/setup.py
+++ b/setup.py
@@ -927,15 +927,22 @@ class pyside_build(_build):
vars=vars)
-def read(fname):
- return open(os.path.join(os.path.dirname(__file__), fname)).read()
+try:
+ with open(os.path.join(script_dir, 'README.rst')) as f:
+ README = f.read()
+ with open(os.path.join(script_dir, 'CHANGES.rst')) as f:
+ CHANGES = "Changes" + "\n" + \
+ "=======" + "\n\n" + \
+ f.read()
+except IOError:
+ README = CHANGES = ''
+
setup(
name = "PySide",
version = __version__,
description = ("Python bindings for the Qt cross-platform application and UI framework"),
- long_description = open("README.rst").read() + "\n" +
- open("CHANGES.rst").read(),
+ long_description = README + "\n\n" + CHANGES,
options = {
"bdist_wininst": {
"install_script": "pyside_postinstall.py",