aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2018-04-11 13:53:27 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2018-04-20 10:57:29 +0000
commita861c09fd13d4657191c2d447d7f7d3db5d42d5e (patch)
tree647f87bf9d02539e165c1294b98bec0d54191532 /setup.py
parenta63bf4c49d29747ac1cfeaae2e802ad7ccd34336 (diff)
Fix QtWebEngineProcess related issues on the supported platforms
There were 2 issues: 1) QtWebEngineProcess could not be found on Windows because we have a non-standard directory layout for the Qt files we copy over (there is no bin directory), so we need to adjust the internal qt.conf which is set in pyside.cpp 2) QtWebEngineProcess itself does not use the qt.conf from pyside.cpp, because it is a separate executable, and thus we need to supply a qt.conf specifically for it which is placed in the libexec folder. Task-number: PYSIDE-626 Task-number: PYSIDE-631 Task-number: PYSIDE-642 Change-Id: I75d1b083fb5afe5dc31ba90174f42c7f559c5cd5 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 18 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 947f78106..7e38188a9 100644
--- a/setup.py
+++ b/setup.py
@@ -1557,6 +1557,12 @@ class pyside_build(_build):
force=False,
vars=vars)
+ # Copy the qt.conf file to libexec.
+ copyfile(
+ "{build_dir}/pyside2/PySide2/qt.conf",
+ "{pyside_package_dir}/PySide2/Qt/libexec",
+ vars=vars)
+
def prepare_standalone_package_osx(self, executables, vars):
built_modules = vars['built_modules']
@@ -1643,6 +1649,12 @@ class pyside_build(_build):
rpath = "@loader_path/../lib"
osx_fix_rpaths_for_library(final_path, rpath)
+ # Copy the qt.conf file to libexec.
+ copyfile(
+ "{build_dir}/pyside2/PySide2/qt.conf",
+ "{pyside_package_dir}/PySide2/Qt/libexec",
+ vars=vars)
+
# <qt>/plugins/* -> <setup>/PySide2/Qt/plugins
copydir("{qt_plugins_dir}",
"{pyside_package_dir}/PySide2/Qt/plugins",
@@ -1930,6 +1942,12 @@ class pyside_build(_build):
filter=[filter],
recursive=False, vars=vars)
+ # Copy the qt.conf file to prefix dir.
+ copyfile(
+ "{build_dir}/pyside2/PySide2/qt.conf",
+ "{pyside_package_dir}/PySide2",
+ vars=vars)
+
self.prepare_standalone_clang(is_win=True)
# pdb files for libshiboken and libpyside