aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2018-04-09 11:53:45 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2018-04-20 10:57:23 +0000
commite755915872c57d5091b1dfc643f12ade8f567ba6 (patch)
tree0654fd06495d26c01bb3daab32fc102bad9bde79 /setup.py
parentb074d562ad142d349fd44a2b72c03005025325cd (diff)
Fail early in setup.py when clang can not be found
Previously only a warning was printed when clang could not be found at setup.py time, resulting in a not very nice to parse CMake error. Make sure to fail early in setup.py if clang can not be found. Also make sure to check that the clang source variable0 is not "None", because passing "None" to run_process_output results in an even more obscure Python error. Change-Id: Ia94bf7da51996a3d9c74d5d9978b1bf9e26b03d5 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e7553aacb..462913532 100644
--- a/setup.py
+++ b/setup.py
@@ -905,8 +905,8 @@ class pyside_build(_build):
clangBinDir, clangDir[1]))
additionalPaths.append(clangBinDir)
else:
- log.error("Failed to detect Clang by checking "
- "LLVM_INSTALL_DIR, CLANG_INSTALL_DIR, llvm-config")
+ raise DistutilsSetupError("Failed to detect Clang when checking "
+ "LLVM_INSTALL_DIR, CLANG_INSTALL_DIR, llvm-config")
update_env_path(additionalPaths)