aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2018-05-18 16:45:35 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2018-05-18 16:45:35 +0200
commit3f8c8702ea295f39357e7c66f46e5138f56bcc9f (patch)
tree9ca65a7f94d544ba4b36f239c4a48852ad8a7b09 /sources/pyside2/CMakeLists.txt
parent5fce76074c01e52a22151133a1e3a2cf71cfe535 (diff)
parentdf1a619d65d8e5db91f3c8db46b00872b461e334 (diff)
Merge remote-tracking branch 'origin/5.9' into 5.11
Diffstat (limited to 'sources/pyside2/CMakeLists.txt')
-rw-r--r--sources/pyside2/CMakeLists.txt28
1 files changed, 20 insertions, 8 deletions
diff --git a/sources/pyside2/CMakeLists.txt b/sources/pyside2/CMakeLists.txt
index 3e56881df..d4150c93b 100644
--- a/sources/pyside2/CMakeLists.txt
+++ b/sources/pyside2/CMakeLists.txt
@@ -17,8 +17,8 @@ if (USE_PYTHON_VERSION)
find_package(PythonInterp ${USE_PYTHON_VERSION} REQUIRED)
find_package(PythonLibs ${USE_PYTHON_VERSION} REQUIRED)
else()
- find_package(PythonInterp 2.6)
- find_package(PythonLibs 2.6)
+ find_package(PythonInterp 2.7)
+ find_package(PythonLibs 2.7)
endif()
set(PYSIDE_VERSION_FILE_PATH "${CMAKE_SOURCE_DIR}/pyside_version.py")
@@ -293,19 +293,20 @@ macro(COLLECT_MODULE_IF_FOUND shortname)
endif()
# If the module was found, and also the module path is the same as the
- # Qt5Core base path, we will generate the list with the modules to be install
+ # Qt5Core base path, we will generate the list with the modules to be installed
+ set(looked_in_message ". Looked in: ${${_name_dir}}")
if("${${_name_found}}" AND (("${found_basepath}" GREATER "0") OR ("${found_basepath}" EQUAL "0")))
- message(STATUS "${module_state} module ${name} found (${ARGN})")
+ message(STATUS "${module_state} module ${name} found (${ARGN})${looked_in_message}")
# record the shortnames for the tests
list(APPEND all_module_shortnames ${shortname})
else()
if("${module_state}" STREQUAL "optional")
- message(STATUS "optional module ${name} skipped")
+ message(STATUS "optional module ${name} skipped${looked_in_message}")
elseif("${module_state}" STREQUAL "essential")
message(STATUS "skipped module ${name} is essential!\n"
- " We do not guarantee that all tests are working.")
+ " We do not guarantee that all tests are working.${looked_in_message}")
else()
- message(FATAL_ERROR "module ${name} MISSING")
+ message(FATAL_ERROR "module ${name} MISSING${looked_in_message}")
endif()
endif()
endmacro()
@@ -340,7 +341,10 @@ endif()
if(WIN32)
list(APPEND ALL_OPTIONAL_MODULES AxContainer)
endif()
-list(APPEND ALL_OPTIONAL_MODULES WebChannel WebEngineCore WebEngineWidgets WebKit WebKitWidgets WebSockets)
+# Disabling WebKit by default
+# If WebKit support is needed add the following elements
+# to the list: WebKit WebKitWidgets
+list(APPEND ALL_OPTIONAL_MODULES WebChannel WebEngineCore WebEngineWidgets WebSockets)
if (Qt5Core_VERSION VERSION_GREATER 5.9.3) # Depending on fixes in Qt3D
list(APPEND ALL_OPTIONAL_MODULES 3DCore 3DRender 3DInput 3DLogic 3DAnimation 3DExtras)
endif()
@@ -350,6 +354,14 @@ if (NOT MODULES)
set(MODULES "${ALL_ESSENTIAL_MODULES};${ALL_OPTIONAL_MODULES}")
endif()
+# Removing from the MODULES list the items that were defined with
+# -DSKIP_MODULES on command line
+if (SKIP_MODULES)
+ foreach(s ${SKIP_MODULES})
+ list(REMOVE_ITEM MODULES ${s})
+ endforeach()
+endif()
+
foreach(m ${MODULES})
COLLECT_MODULE_IF_FOUND(${m})
endforeach()