aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtGui/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2019-09-03 14:15:54 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2019-09-25 08:06:08 +0200
commitaeccae345301738e8bd9016739ce0113d40301a6 (patch)
tree54ce554746627b2339d6963888f58f2f6f723d0e /sources/pyside2/PySide2/QtGui/CMakeLists.txt
parentb7f63eadeb1b6a3791797e7ecaeb191997395965 (diff)
Add bindings for Qt 5.14
Task-number: PYSIDE-487 Change-Id: I52b4c13f881599812a311f01937fde92ba4c0f3f Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io>
Diffstat (limited to 'sources/pyside2/PySide2/QtGui/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtGui/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/sources/pyside2/PySide2/QtGui/CMakeLists.txt b/sources/pyside2/PySide2/QtGui/CMakeLists.txt
index 18d80f647..9e6bd099f 100644
--- a/sources/pyside2/PySide2/QtGui/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtGui/CMakeLists.txt
@@ -210,6 +210,10 @@ ${QtGui_GEN_DIR}/qwindowstatechangeevent_wrapper.cpp
${QtGui_GEN_DIR}/qtgui_module_wrapper.cpp
)
+if (Qt5Gui_VERSION VERSION_EQUAL 5.14.0 OR Qt5Gui_VERSION VERSION_GREATER 5.14.0)
+ list(APPEND QtGui_SRC ${QtGui_GEN_DIR}/qcolorspace_wrapper.cpp)
+endif()
+
# cf qtbase/src/gui/opengl/opengl.pri
list(FIND QtGui_enabled_features "opengles2" _opengles2Index)
# ### fixme: For cmake >= 3.3: if(opengles2 IN_LIST QtGui_enabled_features)