aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt
diff options
context:
space:
mode:
authorOswald Buddenhagen <oswald.buddenhagen@qt.io>2017-05-22 16:44:51 +0200
committerOswald Buddenhagen <oswald.buddenhagen@qt.io>2017-05-22 18:22:49 +0200
commit427c7147d23fa21c6e8bd08407b1badc48b49c3c (patch)
treed2742c7ffdfa167bcf6e68f06ce7524bc441102d /sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt
parent4ec9cfa3c6b895c0cf50227c189cfa542de88b64 (diff)
move everying into sources/pyside2 (5.9 edition)
in preparation for a subtree merge. this should not be necessary to do in a separate commit, but git is a tad stupid about following history correctly without it.
Diffstat (limited to 'sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt b/sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt
new file mode 100644
index 000000000..0af059ffe
--- /dev/null
+++ b/sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt
@@ -0,0 +1,40 @@
+project(QtX11Extras)
+
+set(QtX11Extras_SRC
+${QtX11Extras_GEN_DIR}/qx11info_wrapper.cpp
+# module is always needed
+${QtX11Extras_GEN_DIR}/qtx11extras_module_wrapper.cpp
+)
+
+make_path(QtX11Extras_typesystem_path ${QtX11Extras_SOURCE_DIR}
+ ${QtCore_SOURCE_DIR}
+ ${QtCore_BINARY_DIR}
+ ${QtGui_SOURCE_DIR}
+ ${QtGui_BINARY_DIR})
+
+set(QtX11Extras_include_dirs ${QtX11Extras_SOURCE_DIR}
+ ${QtX11Extras_BINARY_DIR}
+ ${Qt5X11Extras_INCLUDE_DIRS}
+ ${Qt5Core_INCLUDE_DIRS}
+ ${Qt5Gui_INCLUDE_DIRS}
+ ${QtCore_GEN_DIR}
+ ${QtGui_GEN_DIR}
+ ${SHIBOKEN_PYTHON_INCLUDE_DIR}
+ ${SHIBOKEN_INCLUDE_DIR}
+ ${libpyside_SOURCE_DIR})
+
+set(QtX11Extras_libraries pyside2
+ ${Qt5X11Extras_LIBRARIES}
+ ${SHIBOKEN_PYTHON_LIBRARIES}
+ ${Qt5Core_LIBRARIES}
+ ${Qt5Gui_LIBRARIES})
+
+set(QtX11Extras_deps QtCore QtGui)
+
+create_pyside_module(QtX11Extras
+ QtX11Extras_include_dirs
+ QtX11Extras_libraries
+ QtX11Extras_deps
+ QtX11Extras_typesystem_path
+ QtX11Extras_SRC
+ "")