aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2017-11-02 14:18:03 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2017-11-06 07:56:25 +0000
commitf2063ee4737f90c5d412a9a328672fde32b033eb (patch)
treebe06749b135fd45a9ca5b0e1d213ef743883dcf5 /sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt
parent0de4dffa0c5abc80df7063daf6bc9d1754891a9d (diff)
PySide2: Simplify typesystem path handling
Modify the typesystem.xml files such that all dependent files are loaded via module (for example, QtCore/typesystem_core.xml). As a result, it is no longer necessary to add each dependent directory to the typesystem path; it is sufficient to pass the binary and source path of PySide2 and the source directory of the Qt module only. This requires rewriting the dependency checking for --reuse-build so that it loops over the source directories of the dependent Qt modules. Change-Id: Ib234c2673f4ee93cc8a3282fac69bcfcfaebd0ac Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt')
-rw-r--r--sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt b/sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt
index 0af059ffe..f15f77375 100644
--- a/sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt
+++ b/sources/pyside2/PySide2/QtX11Extras/CMakeLists.txt
@@ -6,12 +6,6 @@ ${QtX11Extras_GEN_DIR}/qx11info_wrapper.cpp
${QtX11Extras_GEN_DIR}/qtx11extras_module_wrapper.cpp
)
-make_path(QtX11Extras_typesystem_path ${QtX11Extras_SOURCE_DIR}
- ${QtCore_SOURCE_DIR}
- ${QtCore_BINARY_DIR}
- ${QtGui_SOURCE_DIR}
- ${QtGui_BINARY_DIR})
-
set(QtX11Extras_include_dirs ${QtX11Extras_SOURCE_DIR}
${QtX11Extras_BINARY_DIR}
${Qt5X11Extras_INCLUDE_DIRS}
@@ -35,6 +29,6 @@ create_pyside_module(QtX11Extras
QtX11Extras_include_dirs
QtX11Extras_libraries
QtX11Extras_deps
- QtX11Extras_typesystem_path
+ QtX11Extras_SOURCE_DIR
QtX11Extras_SRC
"")