aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/tests/QtCore/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-05-07 07:56:20 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-05-18 15:13:21 +0200
commit0c6e4506e5c0b6aacdf48fd777eb452d91732157 (patch)
tree92a94c6ad5f13a1fbece06896b11763b3c830769 /sources/pyside2/tests/QtCore/CMakeLists.txt
parent59352c3ed2364e09b9c4dae91bd7a16755ea4d95 (diff)
pyside2: Prepare build system for Qt 6
- Introduce a version variable to the CMakeLists. - Emulate the Qt5Core_INCLUDE_DIRS, Qt5Core_LIBRARIES variables by retrieving them from the INTERFACE - Raise the language level Task-number: PYSIDE-904 Change-Id: Ie4e43e7e6a9a2631d666038b80f306e2d9af47b1 Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'sources/pyside2/tests/QtCore/CMakeLists.txt')
-rw-r--r--sources/pyside2/tests/QtCore/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/sources/pyside2/tests/QtCore/CMakeLists.txt b/sources/pyside2/tests/QtCore/CMakeLists.txt
index 35e42e2ae..a151e6d11 100644
--- a/sources/pyside2/tests/QtCore/CMakeLists.txt
+++ b/sources/pyside2/tests/QtCore/CMakeLists.txt
@@ -52,7 +52,8 @@ PYSIDE_TEST(qbytearray_concatenation_operator_test.py)
PYSIDE_TEST(qbytearray_operator_iadd_test.py)
PYSIDE_TEST(qbytearray_operator_test.py)
PYSIDE_TEST(qbytearray_test.py)
-if (Qt5Core_VERSION VERSION_EQUAL 5.14.0 OR Qt5Core_VERSION VERSION_GREATER 5.14.0)
+if (Qt${QT_MAJOR_VERSION}Core_VERSION VERSION_EQUAL 5.14.0
+ OR Qt${QT_MAJOR_VERSION}Core_VERSION VERSION_GREATER 5.14.0)
PYSIDE_TEST(qcalendar_test.py)
endif()
PYSIDE_TEST(qcbor_test.py)