aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/tests/QtCore/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2019-09-03 14:14:00 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2019-09-05 01:38:14 +0200
commit3dcef048966bf0783cec66bf7e63307a1182cadf (patch)
tree47955878593acd80935a4a15c1f58f9f3a2aa00f /sources/pyside2/tests/QtCore/CMakeLists.txt
parent155a2608309f44757bfa6433a44129e306cd5cce (diff)
Add Qt Core bindings for Qt 5.14
Adding the new QCalendar class is required to unlock the branch since the rejected constructor QDate(int, int, int, QCalendar) causes test failures in of QDate. Task-number: PYSIDE-487 Change-Id: I2720b92f3356421065f539ea0eba75d3049b9702 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io>
Diffstat (limited to 'sources/pyside2/tests/QtCore/CMakeLists.txt')
-rw-r--r--sources/pyside2/tests/QtCore/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/sources/pyside2/tests/QtCore/CMakeLists.txt b/sources/pyside2/tests/QtCore/CMakeLists.txt
index d05699f16..35e42e2ae 100644
--- a/sources/pyside2/tests/QtCore/CMakeLists.txt
+++ b/sources/pyside2/tests/QtCore/CMakeLists.txt
@@ -52,6 +52,9 @@ PYSIDE_TEST(qbytearray_concatenation_operator_test.py)
PYSIDE_TEST(qbytearray_operator_iadd_test.py)
PYSIDE_TEST(qbytearray_operator_test.py)
PYSIDE_TEST(qbytearray_test.py)
+if (Qt5Core_VERSION VERSION_EQUAL 5.14.0 OR Qt5Core_VERSION VERSION_GREATER 5.14.0)
+ PYSIDE_TEST(qcalendar_test.py)
+endif()
PYSIDE_TEST(qcbor_test.py)
PYSIDE_TEST(qcollator_test.py)
PYSIDE_TEST(qcommandlineparser_test.py)