aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside2/tests/QtCore/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Altendorf <sda@fstab.net>2020-06-12 22:46:49 -0400
committerKyle Altendorf <sda@fstab.net>2020-07-01 12:11:30 -0400
commitd6f460db0f9fcdc2756b29209f21a7b87587881c (patch)
tree981cba443bdb18a7c47c96d60fffa0968810108a /sources/pyside2/tests/QtCore/CMakeLists.txt
parent4c615f2c749e50d157076237d65ed7297fa070b5 (diff)
basewrapper.cpp: add PyErr_Fetch/Restore in SbkDeallocWrapperCommon()
Fixes corruption of the interpreter's internal exception state which can occur for example in a final send to a generator which results in teardown of Python objects. Resolved by adding PyErr_Fetch and PyErr_Restore calls around the deallocation code in SbkDeallocWrapperCommon(). Task-number: PYSIDE-1313 Change-Id: Ie68c7b08d60eec8ca91b4032b21089d66d6e4478 Reviewed-by: Christian Tismer <tismer@stackless.com>
Diffstat (limited to 'sources/pyside2/tests/QtCore/CMakeLists.txt')
-rw-r--r--sources/pyside2/tests/QtCore/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/sources/pyside2/tests/QtCore/CMakeLists.txt b/sources/pyside2/tests/QtCore/CMakeLists.txt
index a151e6d11..7973a51ca 100644
--- a/sources/pyside2/tests/QtCore/CMakeLists.txt
+++ b/sources/pyside2/tests/QtCore/CMakeLists.txt
@@ -26,6 +26,7 @@ PYSIDE_TEST(bug_1019.py)
PYSIDE_TEST(bug_1031.py)
PYSIDE_TEST(bug_1063.py)
PYSIDE_TEST(bug_1069.py)
+PYSIDE_TEST(bug_1313.py)
PYSIDE_TEST(bug_PYSIDE-42.py)
PYSIDE_TEST(bug_PYSIDE-164.py)
PYSIDE_TEST(blocking_signals_test.py)