aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2021-02-05 17:06:16 +0100
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2021-02-16 13:35:45 +0000
commit82afd88245a17b6ba759937a2b391c216857565a (patch)
tree1700964ad26a47e30e470fe679a80c72da17a26a /sources/pyside6/CMakeLists.txt
parentb9aa61247c355a9330e52059951649c6ba7697c2 (diff)
PySide6: Add a Designer plugin
Add a convencience class QPyDesignerCustomWidgetCollection to the Qt Designer module, which provides functions for registering widget types or adding QDesignerCustomWidgetInterface instances. A static instance of it is stored as a dynamic property on QCoreApplication, which is retrieved by a Qt Designer plugin, which provides the collection of widgets registered in Python. Task-number: PYSIDE-1455 Change-Id: If4055e6c9db6a03b32016b013a1130051bbd472a Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io>
Diffstat (limited to 'sources/pyside6/CMakeLists.txt')
-rw-r--r--sources/pyside6/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/sources/pyside6/CMakeLists.txt b/sources/pyside6/CMakeLists.txt
index 77d3690f5..b282553a8 100644
--- a/sources/pyside6/CMakeLists.txt
+++ b/sources/pyside6/CMakeLists.txt
@@ -235,6 +235,7 @@ add_subdirectory(libpyside)
find_package(Qt${QT_MAJOR_VERSION}Designer)
if(Qt${QT_MAJOR_VERSION}UiTools_FOUND AND Qt${QT_MAJOR_VERSION}Designer_FOUND)
add_subdirectory(plugins/uitools)
+ add_subdirectory(plugins/designer)
endif()
# project directories