aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Tismer <tismer@stackless.com>2021-02-08 16:47:54 +0100
committerChristian Tismer <tismer@stackless.com>2021-02-10 14:40:20 +0100
commit8ce4d053ceb0861b56305cdd2e001e864b02f9c2 (patch)
tree6268bff542b81bb203bf4f5056665cb74fa4af8c /sources/pyside6/CMakeLists.txt
parentac7365aa78d78a3693c46e2177df3216d0a40628 (diff)
Switch from os.path to pathlib.Path, all source changes but tests
With this patch, os.path in Shiboken and Pyside will be completely removed from sources. The rest will be done later. Task-number: PYSIDE-1499 Change-Id: Id01782779487ceec62efdd1f32f65beee0234338 Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'sources/pyside6/CMakeLists.txt')
-rw-r--r--sources/pyside6/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/sources/pyside6/CMakeLists.txt b/sources/pyside6/CMakeLists.txt
index ea8e33a65..77d3690f5 100644
--- a/sources/pyside6/CMakeLists.txt
+++ b/sources/pyside6/CMakeLists.txt
@@ -203,7 +203,7 @@ if (NOT PYTHON_SITE_PACKAGES)
execute_process(
COMMAND ${SHIBOKEN_PYTHON_INTERPRETER} -c "if True:
from distutils import sysconfig
- from os.path import sep
+ from os import sep
print(sysconfig.get_python_lib(1, 0, prefix='${CMAKE_INSTALL_PREFIX}').replace(sep, '/'))
"
OUTPUT_VARIABLE PYTHON_SITE_PACKAGES