aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-04-06 20:29:21 +0200
committerCristian Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-04-06 21:15:31 +0200
commitfbbae556c9bf060be366fd578986cae85ff8caec (patch)
tree68ed77bc0b6b3230d050749457304a0a54d688d6 /sources/pyside6/CMakeLists.txt
parent5109bcc49ee907d15c7e9735f8642f15bef90eb9 (diff)
doc: make sure '--skip-docs' skip the docs
Even when using the code, some portions of the cmake file in sources/pyside6/doc/ was still being executed. This makes sure everything is skipped if we use the '--skip-docs' option when building. Pick-to: 6.0 5.15 Change-Id: If78b19b9650b61b642e447b8c96b814e82994d7c Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'sources/pyside6/CMakeLists.txt')
-rw-r--r--sources/pyside6/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/sources/pyside6/CMakeLists.txt b/sources/pyside6/CMakeLists.txt
index b282553a8..d183257af 100644
--- a/sources/pyside6/CMakeLists.txt
+++ b/sources/pyside6/CMakeLists.txt
@@ -248,7 +248,7 @@ endif ()
find_program(SPHINX_BUILD sphinx-build)
find_program(DOT_EXEC dot)
-if (QT_SRC_DIR AND SPHINX_BUILD AND DOT_EXEC)
+if (QT_SRC_DIR AND SPHINX_BUILD AND DOT_EXEC AND NOT SKIP_DOCS)
add_subdirectory(doc)
else ()
set(DOCS_TARGET_DISABLED_MESSAGE "apidoc generation targets disabled.")