aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtOpenGLFunctions/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2021-03-11 15:31:17 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-03-12 06:16:50 +0000
commit9df5283e034d24e2339de04b3d61e6b03ff52aca (patch)
treef010ee81321c81d200f0dcebe8b4bf9299ed2718 /sources/pyside6/PySide6/QtOpenGLFunctions/CMakeLists.txt
parent5422f65496155fcc9056ed4dda2c8493716d5da8 (diff)
PySide6: Add QOpenGLVersionFunctionsFactory
Make it possible to obtain versioned OpenGL functions. Task-number: PYSIDE-1482 Fixes: PYSIDE-955 Change-Id: Ife315de0aa05ac83610e228389bcf55214e93e55 Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io> (cherry picked from commit 091f488479227c58fd3944d68c48fc7efe223f9e) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'sources/pyside6/PySide6/QtOpenGLFunctions/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtOpenGLFunctions/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/sources/pyside6/PySide6/QtOpenGLFunctions/CMakeLists.txt b/sources/pyside6/PySide6/QtOpenGLFunctions/CMakeLists.txt
index 5ac197801..296c525cf 100644
--- a/sources/pyside6/PySide6/QtOpenGLFunctions/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtOpenGLFunctions/CMakeLists.txt
@@ -39,7 +39,8 @@ else()
${QtOpenGLFunctions_GEN_DIR}/qopenglfunctions_4_4_compatibility_wrapper.cpp
${QtOpenGLFunctions_GEN_DIR}/qopenglfunctions_4_4_core_wrapper.cpp
${QtOpenGLFunctions_GEN_DIR}/qopenglfunctions_4_5_compatibility_wrapper.cpp
- ${QtOpenGLFunctions_GEN_DIR}/qopenglfunctions_4_5_core_wrapper.cpp)
+ ${QtOpenGLFunctions_GEN_DIR}/qopenglfunctions_4_5_core_wrapper.cpp
+ ${QtOpenGLFunctions_GEN_DIR}/qopenglversionfunctionsfactory_wrapper.cpp)
message(STATUS "Qt${QT_MAJOR_VERSION}OpenGLFunctions: Adding Desktop OpenGL classes")
endif()