aboutsummaryrefslogtreecommitdiffstats
path: root/sources/pyside6/PySide6/QtScxml/CMakeLists.txt
diff options
context:
space:
mode:
authorCristian Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-04-06 22:57:42 +0200
committerCristian Maureira-Fredes <Cristian.Maureira-Fredes@qt.io>2021-04-08 23:00:58 +0200
commit6f7c6833a81d47c53b8596c93d8f1ad5ed785e69 (patch)
tree8e3bf8eef464cb217337a4e5e91d6c5845894c68 /sources/pyside6/PySide6/QtScxml/CMakeLists.txt
parent386f79a2b3725bd6158bfc668772d6b84cf0c1b0 (diff)
cmake: update minimum Qt version for 6.0+ compat
Bumping modules compatibility, using 6.0.0 as the base since we the rename from PySide2 took place already, and this code is not supposed to be backward compatible. Change-Id: I471b151ef50f5a5974561bf2e619017f7beb621a Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io> (cherry picked from commit 985ee0b6e55bc116f287ff2a09265fd3ef629f37) Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io>
Diffstat (limited to 'sources/pyside6/PySide6/QtScxml/CMakeLists.txt')
-rw-r--r--sources/pyside6/PySide6/QtScxml/CMakeLists.txt14
1 files changed, 4 insertions, 10 deletions
diff --git a/sources/pyside6/PySide6/QtScxml/CMakeLists.txt b/sources/pyside6/PySide6/QtScxml/CMakeLists.txt
index 8cb78c9ee..5eaa40a43 100644
--- a/sources/pyside6/PySide6/QtScxml/CMakeLists.txt
+++ b/sources/pyside6/PySide6/QtScxml/CMakeLists.txt
@@ -6,10 +6,14 @@ set(QtScxml_DROPPED_ENTRIES )
set(QtScxml_SRC
${QtScxml_GEN_DIR}/qscxmlcompiler_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlcompiler_loader_wrapper.cpp
+${QtScxml_GEN_DIR}/qscxmlcppdatamodel_wrapper.cpp
+${QtScxml_GEN_DIR}/qscxmldatamodel_foreachloopbody_wrapper.cpp
+${QtScxml_GEN_DIR}/qscxmldatamodel_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlevent_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmldynamicscxmlservicefactory_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlinvokableservice_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlinvokableservicefactory_wrapper.cpp
+${QtScxml_GEN_DIR}/qscxmlnulldatamodel_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlstaticscxmlservicefactory_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmlstatemachine_wrapper.cpp
${QtScxml_GEN_DIR}/qscxmltabledata_wrapper.cpp
@@ -24,16 +28,6 @@ ${QtScxml_GEN_DIR}/qscxmlexecutablecontent_parameterinfo_wrapper.cpp
${QtScxml_GEN_DIR}/qtscxml_module_wrapper.cpp
)
-if (Qt${QT_MAJOR_VERSION}Scxml_VERSION VERSION_EQUAL 5.12.0
- OR Qt${QT_MAJOR_VERSION}Scxml_VERSION VERSION_GREATER 5.12.0)
- list(APPEND QtScxml_SRC
- ${QtScxml_GEN_DIR}/qscxmldatamodel_wrapper.cpp
- ${QtScxml_GEN_DIR}/qscxmldatamodel_foreachloopbody_wrapper.cpp
- ${QtScxml_GEN_DIR}/qscxmlecmascriptdatamodel_wrapper.cpp
- ${QtScxml_GEN_DIR}/qscxmlcppdatamodel_wrapper.cpp
- ${QtScxml_GEN_DIR}/qscxmlnulldatamodel_wrapper.cpp)
-endif()
-
set(QtScxml_include_dirs ${QtScxml_SOURCE_DIR}
${QtScxml_BINARY_DIR}
${Qt${QT_MAJOR_VERSION}Core_INCLUDE_DIRS}