aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/ApiExtractor/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2018-06-21 13:58:49 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2018-06-23 06:49:09 +0000
commitf0179e7e9c19415f1142b366a248ecfce09ad006 (patch)
tree301a65550c8e5bb977fc4431c97ac7d170b72bb4 /sources/shiboken2/ApiExtractor/CMakeLists.txt
parentcf4dc77a973fa488594a818381cc9f0941a4f940 (diff)
shiboken: Search for Clang builtin-includes at runtime
Replace the search executed at build time by CMake by a run time search in shiboken since the location at build time typically won't match any more for the deployment case. Task-number: PYSIDE-693 Change-Id: Ib15fbba5d8c3fecf30aaae7195b88a648a7ed0fe Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'sources/shiboken2/ApiExtractor/CMakeLists.txt')
-rw-r--r--sources/shiboken2/ApiExtractor/CMakeLists.txt7
1 files changed, 0 insertions, 7 deletions
diff --git a/sources/shiboken2/ApiExtractor/CMakeLists.txt b/sources/shiboken2/ApiExtractor/CMakeLists.txt
index a3301a068..b67a352f0 100644
--- a/sources/shiboken2/ApiExtractor/CMakeLists.txt
+++ b/sources/shiboken2/ApiExtractor/CMakeLists.txt
@@ -31,13 +31,6 @@ add_definitions(-DQT_PLUGIN)
add_definitions(-DQT_SHARED)
add_definitions(-DRXX_ALLOCATOR_INIT_0)
-# Pass the path to the clang includes dir, so it headers like stdarg.h.
-if(UNIX AND NOT APPLE)
- add_definitions(-DCLANG_BUILTIN_INCLUDES_DIR="${CLANG_BUILTIN_INCLUDES_DIR}")
-else()
- add_definitions(-DCLANG_BUILTIN_INCLUDES_DIR="")
-endif()
-
set(apiextractor_SRC
apiextractor.cpp
abstractmetabuilder.cpp