aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/generator/CMakeLists.txt
diff options
context:
space:
mode:
authorOswald Buddenhagen <oswald.buddenhagen@qt.io>2017-05-22 17:50:30 +0200
committerOswald Buddenhagen <oswald.buddenhagen@qt.io>2017-05-22 17:50:30 +0200
commit170d47f92d03b81e74e8623cf15db9282957452d (patch)
tree3da6eb4446b42619c21a4ed591988529b75b1a3e /sources/shiboken2/generator/CMakeLists.txt
parent6c018822ba40cc0a4427bd3f9ab8c96829c207df (diff)
move everying into sources/shiboken2
in preparation for a subtree merge. this should not be necessary to do in a separate commit, but git is a tad stupid about following history correctly without it.
Diffstat (limited to 'sources/shiboken2/generator/CMakeLists.txt')
-rw-r--r--sources/shiboken2/generator/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/sources/shiboken2/generator/CMakeLists.txt b/sources/shiboken2/generator/CMakeLists.txt
new file mode 100644
index 000000000..032118666
--- /dev/null
+++ b/sources/shiboken2/generator/CMakeLists.txt
@@ -0,0 +1,40 @@
+project(shibokengenerator)
+
+find_package(Qt5Xml)
+find_package(Qt5XmlPatterns)
+
+set(shiboken2_SRC
+generator.cpp
+shiboken2/cppgenerator.cpp
+shiboken2/headergenerator.cpp
+shiboken2/overloaddata.cpp
+shiboken2/shibokengenerator.cpp
+main.cpp
+)
+
+if (NOT DISABLE_DOCSTRINGS)
+ set(shiboken2_SRC ${shiboken2_SRC} qtdoc/qtdocgenerator.cpp)
+ add_definitions(-DDOCSTRINGS_ENABLED)
+endif()
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}/shiboken2
+ ${CMAKE_CURRENT_SOURCE_DIR}/qtdoc
+ ${CMAKE_CURRENT_SOURCE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${apiextractor_SOURCE_DIR}
+ ${Qt5Core_INCLUDE_DIRS}
+ ${Qt5XmlPatterns_INCLUDE_DIRS}
+ )
+
+add_executable(shiboken2 ${shiboken2_SRC})
+add_dependencies(shiboken2 apiextractor)
+set_target_properties(shiboken2 PROPERTIES OUTPUT_NAME shiboken2${shiboken2_SUFFIX})
+target_link_libraries(shiboken2
+ apiextractor
+ ${Qt5Core_LIBRARIES}
+ ${Qt5XmlPatterns_LIBRARIES}
+ )
+
+configure_file(shibokenconfig.h.in "${CMAKE_CURRENT_BINARY_DIR}/shibokenconfig.h" @ONLY)
+
+install(TARGETS shiboken2 DESTINATION bin)