aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Tismer <tismer@stackless.com>2017-12-17 19:12:56 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2018-05-30 18:13:41 +0000
commit18dc31becdd994c53a9f894087cf1ef99fbd0232 (patch)
tree3021cfa473f20102bfb63a26117776615b91b526 /sources/shiboken2/libshiboken/CMakeLists.txt
parent50dd4ae202d7afb3556335c056db003f5ef50532 (diff)
PEP 384-squash: Implement PEP 384
This is the condensed checkin of 18 commits which created the implementation of PEP 384. Task-number: PYSIDE-560 Change-Id: I834c659af4c2b55b268f8e8dc4cfa53f02502409 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'sources/shiboken2/libshiboken/CMakeLists.txt')
-rw-r--r--sources/shiboken2/libshiboken/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/sources/shiboken2/libshiboken/CMakeLists.txt b/sources/shiboken2/libshiboken/CMakeLists.txt
index e87cf07fd..b5ba78e15 100644
--- a/sources/shiboken2/libshiboken/CMakeLists.txt
+++ b/sources/shiboken2/libshiboken/CMakeLists.txt
@@ -48,7 +48,10 @@ threadstatesaver.cpp
shibokenbuffer.cpp
signature.cpp
qapp_macro.cpp
+pep384impl.cpp
voidptr.cpp
+typespec.cpp
+bufferprocs27.cpp
)
get_numpy_location()
@@ -89,9 +92,12 @@ install(FILES
threadstatesaver.h
shibokenbuffer.h
sbkpython.h
+ pep384impl.h
signature.h
qapp_macro.h
voidptr.h
+ typespec.h
+ bufferprocs27.h
"${CMAKE_CURRENT_BINARY_DIR}/sbkversion.h"
DESTINATION include/shiboken2${shiboken2_SUFFIX})
install(TARGETS libshiboken EXPORT shiboken2