aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/libshiboken/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Tismer <tismer@stackless.com>2020-09-23 18:44:23 +0200
committerChristian Tismer <tismer@stackless.com>2020-09-25 11:07:55 +0200
commit027e380dc9f658925d5d28d6eb368749afb6be65 (patch)
tree8658314f54ab97302ef6b43fe08e157445c523d8 /sources/shiboken2/libshiboken/CMakeLists.txt
parent0c8ada75b639ad8689d165ef617f25aeddfc16eb (diff)
Signature: Break the source into multiple files
The signature module has grown groups of rather unrelated topics. In order to reduce the complexity, we break up the source into a number of files. Reason for this change was building support for selectable features, which should not get lost in all the unrelated helper functions. Task-number: PYSIDE-510 Task-number: PYSIDE-1019 Change-Id: I8e22a91db1882f8c5428b8def13bf9f1cea431fb Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'sources/shiboken2/libshiboken/CMakeLists.txt')
-rw-r--r--sources/shiboken2/libshiboken/CMakeLists.txt12
1 files changed, 10 insertions, 2 deletions
diff --git a/sources/shiboken2/libshiboken/CMakeLists.txt b/sources/shiboken2/libshiboken/CMakeLists.txt
index dee5dbd21..a53402e0f 100644
--- a/sources/shiboken2/libshiboken/CMakeLists.txt
+++ b/sources/shiboken2/libshiboken/CMakeLists.txt
@@ -57,14 +57,19 @@ sbkstaticstrings.cpp
bindingmanager.cpp
threadstatesaver.cpp
shibokenbuffer.cpp
-signature.cpp
qapp_macro.cpp
pep384impl.cpp
voidptr.cpp
typespec.cpp
bufferprocs_py37.cpp
+
embed/signature_bootstrap_inc.h
embed/signature_inc.h
+
+signature/signature.cpp
+signature/signature_globals.cpp
+signature/signature_extend.cpp
+signature/signature_helper.cpp
)
get_numpy_location()
@@ -137,12 +142,15 @@ install(FILES
shibokenbuffer.h
sbkpython.h
pep384impl.h
- signature.h
qapp_macro.h
voidptr.h
typespec.h
bufferprocs_py37.h
"${CMAKE_CURRENT_BINARY_DIR}/sbkversion.h"
+
+ signature.h
+ signature/signature_p.h
+
DESTINATION include/shiboken2${shiboken2_SUFFIX})
install(TARGETS libshiboken EXPORT Shiboken2Targets
LIBRARY DESTINATION "${LIB_INSTALL_DIR}"