aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken2/shibokenmodule/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2017-05-24 18:50:44 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2017-07-12 12:44:47 +0000
commit5337435edaa10518c4495d480f934e87b2ccd444 (patch)
tree9d4d876f0b9c163721dba1210de008045af6559f /sources/shiboken2/shibokenmodule/CMakeLists.txt
parent8ae4d5827d1ccd463b99aaf54c2e8cb482094c91 (diff)
Fix Windows module extensions and tests to work with --debug build
Use the same imp.get_suffixes() mechanism as on Unix, to determine the suffix part of module extension files. This fixes debug builds to work on Windows. Note that the whole build stack has to use the same configuration, no mixing is allowed on Windows. For release build you need: python.exe + setup.py without --debug flag + release build of Qt5. For debug build you need: python_d.exe + setup.py with --debug flag + debug build of Qt5. Change-Id: I6188c859b5757d11e87d6a9e32b9ba558f7f609e Reviewed-by: Friedemann Kleint <Friedemann.Kleint@qt.io>
Diffstat (limited to 'sources/shiboken2/shibokenmodule/CMakeLists.txt')
-rw-r--r--sources/shiboken2/shibokenmodule/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/sources/shiboken2/shibokenmodule/CMakeLists.txt b/sources/shiboken2/shibokenmodule/CMakeLists.txt
index 5e8e39d5f..31b98132d 100644
--- a/sources/shiboken2/shibokenmodule/CMakeLists.txt
+++ b/sources/shiboken2/shibokenmodule/CMakeLists.txt
@@ -27,9 +27,6 @@ set_property(TARGET shibokenmodule PROPERTY PREFIX "")
set_property(TARGET shibokenmodule PROPERTY OUTPUT_NAME "shiboken2${PYTHON_EXTENSION_SUFFIX}")
if(WIN32)
- if(CMAKE_BUILD_TYPE STREQUAL "Debug")
- set_property(TARGET shibokenmodule PROPERTY OUTPUT_NAME "shiboken2_d")
- endif()
set_property(TARGET shibokenmodule PROPERTY SUFFIX ".pyd")
endif()
target_link_libraries(shibokenmodule