aboutsummaryrefslogtreecommitdiffstats
path: root/sources/shiboken6/CMakeLists.txt
diff options
context:
space:
mode:
authorChristian Tismer <tismer@stackless.com>2021-03-20 19:24:38 +0100
committerQt Cherry-pick Bot <cherrypick_bot@qt-project.org>2021-05-17 10:31:36 +0000
commitcf6b7be1328025f2c8be9ad0fcf52cfde041d1a0 (patch)
treeba227abc5ecab509bb0cd0bc6a7382d980c73560 /sources/shiboken6/CMakeLists.txt
parentf4890761767f911c4a8fb33dae088d44436a6032 (diff)
Turn generate_pyi into a general pyi_generator tool, preparation
generate_pyi is now split into a pyi_generator in signature.lib and the remaining stub in generate_pyi.py . This is the first step in the transformation. Task-number: PYSIDE-1415 Change-Id: I7b9075d3f6d8d2b8f8efa4591234f89d4bbe3e46 Reviewed-by: Cristian Maureira-Fredes <cristian.maureira-fredes@qt.io> (cherry picked from commit 71a0e10ba935a2788da4962e0f06880e3d3d0d5d) Reviewed-by: Qt Cherry-pick Bot <cherrypick_bot@qt-project.org>
Diffstat (limited to 'sources/shiboken6/CMakeLists.txt')
-rw-r--r--sources/shiboken6/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/sources/shiboken6/CMakeLists.txt b/sources/shiboken6/CMakeLists.txt
index 3b7418e88..07eabd635 100644
--- a/sources/shiboken6/CMakeLists.txt
+++ b/sources/shiboken6/CMakeLists.txt
@@ -195,6 +195,7 @@ endif()
set(shiboken_python_files
"signature/lib/__init__.py"
"signature/lib/enum_sig.py"
+ "signature/lib/pyi_generator.py"
"signature/lib/tool.py"
"signature/__init__.py"
"signature/errorhandler.py"