aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2011-01-13 15:00:12 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-09 19:10:13 -0300
commit175871f9468b083a59554394ef2fa72ef6098070 (patch)
tree3d4b63898cda7f93067d8abbeb4960e87001045d /tests/CMakeLists.txt
parente3f8e67d859a6fd005c3569fb8fc3695ad4029b0 (diff)
Un-hardcode test resources pathsb-0.9.3
Instead of hardcoding (through the __FILE__ macro) use the current application directory to find the resources. The previous scheme didn't allow running the tests when the source code isn't available. List of resources: - a.xml -> testmodifydocumentation - utf8code.txt -> testcodeinjection Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Reviewer: Hugo Lima <hugo.lima@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 250246645..8660ff1c1 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -15,6 +15,8 @@ declare_test(testabstractmetatype)
declare_test(testaddfunction)
declare_test(testarrayargument)
declare_test(testcodeinjection)
+configure_file("${CMAKE_CURRENT_SOURCE_DIR}/utf8code.txt"
+ "${CMAKE_CURRENT_BINARY_DIR}/utf8code.txt" COPYONLY)
declare_test(testcontainer)
declare_test(testconversionoperator)
declare_test(testconversionruletag)
@@ -39,5 +41,7 @@ declare_test(testtoposort)
declare_test(testvoidarg)
if (NOT DISABLE_DOCSTRINGS)
declare_test(testmodifydocumentation)
+ configure_file("${CMAKE_CURRENT_SOURCE_DIR}/a.xml"
+ "${CMAKE_CURRENT_BINARY_DIR}/a.xml" COPYONLY)
endif()