aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-09-21 14:51:26 -0300
committerHugo Lima <hugo.lima@openbossa.org>2009-09-21 14:52:09 -0300
commit9af36fbb64f19842c0cc797c0b586b3a686805e8 (patch)
tree6bbc050ded0f85517ea75f5dc6dc1ed172168248 /tests/CMakeLists.txt
parentaa12538d63685ef8f75adaa79411b751929b727d (diff)
Added all original pyside unit tests to the shiboken version.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 000000000..915c1664d
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,16 @@
+
+file(GLOB TEST_FILES */*_test.py)
+
+foreach(test_file ${TEST_FILES})
+ string(REGEX MATCH "/([^/]+)//?([^/]+)_test.py" test_name ${test_file} )
+ add_test(${CMAKE_MATCH_1}_${CMAKE_MATCH_2} sh
+ ${CMAKE_CURRENT_SOURCE_DIR}/run_test.sh
+ "${pysidebase_BINARY_DIR}"
+ "${CMAKE_BINARY_DIR}:${CMAKE_CURRENT_SOURCE_DIR}/util"
+ ${PYTHON_EXECUTABLE}
+ ${test_file})
+ set_tests_properties(${CMAKE_MATCH_1}_${CMAKE_MATCH_2} PROPERTIES TIMEOUT 5)
+# Should set python path here
+# Looks like it's fixed in 2.8:
+# http://www.vtk.org/Bug/print_bug_page.php?bug_id=7885
+endforeach(test_file ${TEST_FILES})