aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLuciano Wolf <luciano.wolf@openbossa.org>2010-07-14 18:38:13 -0300
committerLuciano Wolf <luciano.wolf@openbossa.org>2010-07-15 10:13:21 -0300
commitc62c36a64dd4c0fc0cd586c5c2b3d4f97ba3f769 (patch)
tree3fd5931f6ca6a3ff7eda1f60e0963cbae7c36243 /tests/CMakeLists.txt
parent28d0c480b15d566cabfb63dc6cc65697dc5b5edc (diff)
Fix CMakeLists to include QtMultimedia tests + fix audio test.
Reviewer: Renato Araújo <renato.filho@openbossa.org> Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index adf41791d..904d10694 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -25,6 +25,18 @@ macro(PYSIDE_TEST)
WILL_FAIL ${EXPECT_TO_FAIL})
endmacro(PYSIDE_TEST)
+# Try to find QtMultimedia
+# TODO: Remove this hack when cmake support QtMultimedia module
+if (NOT QT_QTMULTIMEDIA_FOUND AND ${QTVERSION} VERSION_GREATER 4.5.9)
+ find_path(QT_QTMULTIMEDIA_INCLUDE_DIR QtMultimedia
+ PATHS ${QT_HEADERS_DIR}/QtMultimedia
+ ${QT_LIBRARY_DIR}/QtMultimedia.framework/Headers
+ NO_DEFAULT_PATH)
+ find_library(QT_QTMULTIMEDIA_LIBRARY QtMultimedia PATHS ${QT_LIBRARY_DIR} NO_DEFAULT_PATH)
+ if (QT_QTMULTIMEDIA_INCLUDE_DIR AND QT_QTMULTIMEDIA_LIBRARY)
+ set(QT_QTMULTIMEDIA_FOUND ON)
+ endif()
+endif ()
add_subdirectory(signals)
TEST_QT_MODULE(QT_QTCORE_FOUND QtCore)