aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAnderson Lizardo <anderson.lizardo@openbossa.org>2010-02-03 09:57:41 -0400
committerHugo Lima <hugo.lima@openbossa.org>2010-02-03 16:53:06 -0200
commit0fd47ac015e1eb01d06150ee453e52aac904f1e7 (patch)
treec995c9c344c3acf10813bdddbb6374d67cf4d1d6 /tests/CMakeLists.txt
parentb7da6f1362e7acffcd64ca7c09cd5c522395ae05 (diff)
Add missing PythonInterp check
tests/CMakeLists.txt uses PYTHON_EXECUTABLE without calling find_package(PythonInterp), making this variable empty and thus not calling the correct interpreter (especially inside Scratchbox).
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 98068f018..db1fdd2da 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -7,6 +7,8 @@ file(GLOB TEST_FILES samplebinding/*_test.py otherbinding/*_test.py)
set(test_blacklist "")
+find_package(PythonInterp REQUIRED)
+
foreach(test_file ${TEST_FILES})
string(REGEX MATCH "/([^/]+)_test.py" test_name ${test_file})
list(FIND test_blacklist ${CMAKE_MATCH_1} expect_fail)