aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorRenato Filho <renato.filho@openbossa.org>2010-07-13 15:01:47 -0300
committerRenato Filho <renato.filho@openbossa.org>2010-07-13 16:04:42 -0300
commit1b1ff6303514314c199d070b9453d5dc80a21d87 (patch)
treee3a8f0f70a133a494e4ffc301a36f3023b35f384 /tests/CMakeLists.txt
parent6988b9cb5d770389123ced8f55cec617b2217ddb (diff)
Use 60 secs to default test timeout.
Reviewer: Marcelo Lira <marcelo.lira@openbossa.org> Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 10ea898c1..645e8b3a6 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -8,6 +8,9 @@ file(GLOB TEST_FILES samplebinding/*_test.py otherbinding/*_test.py)
set(test_blacklist "")
find_package(PythonInterp REQUIRED)
+if(NOT CTEST_TESTING_TIMEOUT)
+ set(CTEST_TESTING_TIMEOUT 60)
+endif()
foreach(test_file ${TEST_FILES})
string(REGEX MATCH "/([^/]+)_test.py" test_name ${test_file})
@@ -18,7 +21,7 @@ foreach(test_file ${TEST_FILES})
"${sample_BINARY_DIR}:${other_BINARY_DIR}"
"${PYTHON_EXECUTABLE}"
"${test_file}")
- set_tests_properties(${CMAKE_MATCH_1} PROPERTIES TIMEOUT 5)
+ set_tests_properties(${CMAKE_MATCH_1} PROPERTIES TIMEOUT ${CTEST_TESTING_TIMEOUT})
if (${expect_fail} GREATER -1)
set_tests_properties(${CMAKE_MATCH_1} PROPERTIES WILL_FAIL TRUE)
endif(${expect_fail} GREATER -1)