aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2011-05-16 12:57:58 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:15:23 -0300
commit973a5389ac0f2a5d899025843b9af9e587eff7d3 (patch)
tree7c2988fd044ef091c56d92683a15f145ce99cd0e /tests/CMakeLists.txt
parent510e7af9a0e9a8b8c0b90ad76453d9ccdf55aedb (diff)
Added a new test binding called 'minimal'.
The purpose is to have the smallest possible binding to help when doing complex changes that require a good deal of debugging and tracking, and the many operations performed in too many wrapped classes will clutter any output used for those purposes. In other words: don't add anything here except with a good reason for it, prefer to use 'sample' or 'other' binding for that. Reviewed by Hugo Parente <hugo.lima@openbossa.org> Reviewed by Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt14
1 files changed, 9 insertions, 5 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index b9d60262f..b6053b530 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,4 @@
+add_subdirectory(libminimal)
add_subdirectory(libsample)
add_subdirectory(libother)
@@ -9,10 +10,13 @@ else()
set(GENERATOR_EXTRA_FLAGS )
endif()
+add_subdirectory(minimalbinding)
add_subdirectory(samplebinding)
add_subdirectory(otherbinding)
-file(GLOB TEST_FILES samplebinding/*_test.py otherbinding/*_test.py)
+file(GLOB TEST_FILES minimalbinding/*_test.py
+ samplebinding/*_test.py
+ otherbinding/*_test.py)
set(test_blacklist "")
@@ -25,16 +29,16 @@ if(CMAKE_VERSION VERSION_LESS 2.8)
message("CMake version greater than 2.8 necessary to run tests")
else()
if(WIN32)
- set(TEST_PYTHONPATH "${sample_BINARY_DIR};${other_BINARY_DIR}")
- set(TEST_LIBRARY_PATH "$ENV{PATH};${libsample_BINARY_DIR};${libother_BINARY_DIR};${libshiboken_BINARY_DIR}")
+ set(TEST_PYTHONPATH "${minimal_BINARY_DIR};${sample_BINARY_DIR};${other_BINARY_DIR}")
+ set(TEST_LIBRARY_PATH "$ENV{PATH};${libminimal_BINARY_DIR};${libsample_BINARY_DIR};${libother_BINARY_DIR};${libshiboken_BINARY_DIR}")
set(LIBRARY_PATH_VAR "PATH")
string(REPLACE "\\" "/" TEST_PYTHONPATH "${TEST_PYTHONPATH}")
string(REPLACE "\\" "/" TEST_LIBRARY_PATH "${TEST_LIBRARY_PATH}")
string(REPLACE ";" "\\;" TEST_PYTHONPATH "${TEST_PYTHONPATH}")
string(REPLACE ";" "\\;" TEST_LIBRARY_PATH "${TEST_LIBRARY_PATH}")
else()
- set(TEST_PYTHONPATH "${sample_BINARY_DIR}:${other_BINARY_DIR}")
- set(TEST_LIBRARY_PATH "$ENV{LD_LIBRARY_PATH}:${libsample_BINARY_DIR}:${libother_BINARY_DIR}:${libshiboken_BINARY_DIR}")
+ set(TEST_PYTHONPATH "${minimal_BINARY_DIR}:${sample_BINARY_DIR}:${other_BINARY_DIR}")
+ set(TEST_LIBRARY_PATH "$ENV{LD_LIBRARY_PATH}:${libminimal_BINARY_DIR}:${libsample_BINARY_DIR}:${libother_BINARY_DIR}:${libshiboken_BINARY_DIR}")
set(LIBRARY_PATH_VAR "LD_LIBRARY_PATH")
endif()