aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-12-02 14:30:46 -0200
committerHugo Lima <hugo.lima@openbossa.org>2009-12-02 14:32:27 -0200
commitd0e43624f8fbe76c0d942c627ccccf0d4ac7960f (patch)
treeef270ca196833cf3dc20b1853fab27ba812dc121 /tests/CMakeLists.txt
parenta84378bff4a45aaba839855d6f9151898adbee52 (diff)
Add test black list.
Reviewed by Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt14
1 files changed, 10 insertions, 4 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index c1569517e..1f8d58485 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -3,15 +3,21 @@ add_subdirectory(samplebinding)
file(GLOB TEST_FILES samplebinding/*_test.py)
+set(test_blacklist "multiple_derived")
+
foreach(test_file ${TEST_FILES})
string(REGEX MATCH "/([^/]+)_test.py" test_name ${test_file})
- add_test(${CMAKE_MATCH_1} sh
- ${CMAKE_CURRENT_SOURCE_DIR}/run_test.sh
+ list(FIND test_blacklist ${CMAKE_MATCH_1} expect_fail)
+ add_test("${CMAKE_MATCH_1}" sh
+ "${CMAKE_CURRENT_SOURCE_DIR}/run_test.sh"
"${libsample_BINARY_DIR}:${libshiboken_BINARY_DIR}"
"${sample_BINARY_DIR}"
- ${PYTHON_EXECUTABLE}
- ${test_file})
+ "${PYTHON_EXECUTABLE}"
+ "${test_file}")
set_tests_properties(${CMAKE_MATCH_1} PROPERTIES TIMEOUT 5)
+ if (${expect_fail} GREATER -1)
+ set_tests_properties(${CMAKE_MATCH_1} PROPERTIES WILL_FAIL TRUE)
+ endif(${expect_fail} GREATER -1)
# Should set python path here
# Looks like it's fixed in 2.8: