aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2010-02-24 19:26:24 -0300
committerLauro Neto <lauro.neto@openbossa.org>2010-02-26 20:23:42 -0300
commitb10d28d07f215ae8f237f038db2a5d90009055c5 (patch)
tree32177f1006fb262f9340914a129d4496e5a8b6a9 /tests/CMakeLists.txt
parentc7199a6ecbe5d4daf95f0e4629ea6cac4526cc19 (diff)
Adding blacklist with qkeysequence test
Reviewer: Hugo Lima <hugo.lima@openbossa.org> Reviewer: Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 915c1664d..2a1d422ce 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,8 +1,11 @@
file(GLOB TEST_FILES */*_test.py)
+set(test_blacklist "qtgui_qstring_qkeysequence")
+
foreach(test_file ${TEST_FILES})
string(REGEX MATCH "/([^/]+)//?([^/]+)_test.py" test_name ${test_file} )
+ list(FIND test_blacklist ${CMAKE_MATCH_1}_${CMAKE_MATCH_2} expect_fail)
add_test(${CMAKE_MATCH_1}_${CMAKE_MATCH_2} sh
${CMAKE_CURRENT_SOURCE_DIR}/run_test.sh
"${pysidebase_BINARY_DIR}"
@@ -10,6 +13,9 @@ foreach(test_file ${TEST_FILES})
${PYTHON_EXECUTABLE}
${test_file})
set_tests_properties(${CMAKE_MATCH_1}_${CMAKE_MATCH_2} PROPERTIES TIMEOUT 5)
+ if (${expect_fail} GREATER -1)
+ set_tests_properties(${CMAKE_MATCH_1}_${CMAKE_MATCH_2} PROPERTIES WILL_FAIL TRUE)
+ endif(${expect_fail} GREATER -1)
# Should set python path here
# Looks like it's fixed in 2.8:
# http://www.vtk.org/Bug/print_bug_page.php?bug_id=7885