aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2010-12-14 16:33:49 -0300
committerLauro Neto <lauro.neto@openbossa.org>2011-01-11 15:50:09 -0300
commit30fcf4f242a1aa37378b86fd4ec89b6905c74aff (patch)
tree9f668ee2a8f77310ca1bdf46ffe8ce7c38712a99 /tests/CMakeLists.txt
parentcb7a4e781352b071ed783b1a3dd0afb283526440 (diff)
Add option to install tests
Reviewer: Marcelo Lira <marcelo.lira@openbossa.org> Reviewer: Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 37c34ea3d..1f123bf72 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -19,4 +19,7 @@ if (NOT APIEXTRACTOR_DOCSTRINGS_DISABLED)
genrunner)
add_test("sphinxtable" sphinxtabletest)
+ if (INSTALL_TESTS)
+ install(PROGRAMS ${CMAKE_CURRENT_BINARY_DIR}/sphinxtabletest DESTINATION ${TEST_INSTALL_DIR})
+ endif()
endif()