aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2009-10-26 11:04:22 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-10-26 11:04:22 -0300
commit3a15584474c9865e23334e30b7cac640dc166a12 (patch)
treea163d0a6fe8e05a1fb8e4143cbcbe4417265f68b /tests/CMakeLists.txt
parentae3abca2b15794bdde313eed3f7f9391cd68f72d (diff)
readded tests for qtdoc generator that were left behind when forking
from boostpythongenerator
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
new file mode 100644
index 000000000..0d28c4419
--- /dev/null
+++ b/tests/CMakeLists.txt
@@ -0,0 +1,20 @@
+project(sphinxtabletest)
+
+# TODO
+set(sphinxtabletest_SRC sphinxtabletest.cpp)
+qt4_automoc(${sphinxtabletest_SRC})
+
+include_directories(${QT_INCLUDE_DIR}
+ ${QT_QTCORE_INCLUDE_DIR}
+ ${CMAKE_CURRENT_BINARY_DIR}
+ ${qtdoc_generator_SOURCE_DIR})
+
+add_executable(sphinxtabletest ${sphinxtabletest_SRC})
+
+target_link_libraries(sphinxtabletest
+ ${QT_QTTEST_LIBRARY}
+ ${APIEXTRACTOR_LIBRARY}
+ qtdoc_generator
+ genrunner)
+
+add_test("sphinxtable" sphinxtabletest)