aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2011-02-04 19:56:28 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2011-02-04 20:11:26 -0300
commitc306628bd2b06ec5a9a734e33a8d948be1811649 (patch)
tree4d2ffed47ccb72cc966072f00358125ba91dbb69 /tests/CMakeLists.txt
parent2456d853d7aa4254ca0ad63b48f667796fc51fe1 (diff)
Added a CMake script that sets some environment variables before calling the tests.
This is used as a workaround to a CMake 2.6 limitation that prevents environment variables to be set for tests. Reviewed by Hugo Parente <hugo.lima@openbossa.org> Reviewed by Lauro Neto <lauro.neto@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt7
1 files changed, 1 insertions, 6 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index b8facb001..82c4d3c7d 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,9 +1,4 @@
-if(CMAKE_VERSION VERSION_LESS 2.8)
- # Versions lesser than 2.8 can not set environment variables for tests.
- message("CMake version greater than 2.8 necessary to run certain tests.")
-else()
- add_subdirectory(test_generator)
-endif()
+add_subdirectory(test_generator)
if (NOT APIEXTRACTOR_DOCSTRINGS_DISABLED)
project(sphinxtabletest)