aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo@setantas.net>2011-02-06 00:41:50 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:15:15 -0300
commit0a5cacdb9c25d79df02d7b201ab1f2277caceca3 (patch)
tree42b56d93f8a30bb4109f259b511ff7e6eaeadaff /tests/CMakeLists.txt
parente8a7efe5905ab8a1b333e5634081b4afcff7c334 (diff)
The option "avoid protected hack" is now set via command line.sb-1.0.0-rc1
Instead of the old ugly way of compiling the behaviour forever using "#define". Reviewed by Hugo Parente <hugo.lima@openbossa.org> Reviewed by Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index dc7c69f68..b9d60262f 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,6 +1,13 @@
add_subdirectory(libsample)
add_subdirectory(libother)
+if(WIN32 OR DEFINED AVOID_PROTECTED_HACK)
+ message(STATUS "Tests will be generated avoiding the protected hack!")
+ set(GENERATOR_EXTRA_FLAGS --avoid-protected-hack)
+else()
+ message(STATUS "Tests will be generated using the protected hack!")
+ set(GENERATOR_EXTRA_FLAGS )
+endif()
add_subdirectory(samplebinding)
add_subdirectory(otherbinding)