aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2011-01-13 10:48:43 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2011-01-25 08:32:20 -0300
commite674a8ddbc11e51f3f701e8ab7783aefec8cfeec (patch)
tree1565cc7b8a5990bdf7a647ed7372d869f152d88a /tests/CMakeLists.txt
parentb5e32ea4f620a0f7e3e2ee6bba741b0f08686312 (diff)
Added a dummy generator as a source of test cases.
Unit tests were added as well.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 1f123bf72..b8facb001 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,3 +1,10 @@
+if(CMAKE_VERSION VERSION_LESS 2.8)
+ # Versions lesser than 2.8 can not set environment variables for tests.
+ message("CMake version greater than 2.8 necessary to run certain tests.")
+else()
+ add_subdirectory(test_generator)
+endif()
+
if (NOT APIEXTRACTOR_DOCSTRINGS_DISABLED)
project(sphinxtabletest)