aboutsummaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-03-22 10:31:34 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-09 19:09:57 -0300
commite8f37f7ee2b7ea6a7d25732dbd335687b5493ec3 (patch)
tree19f7164efa01f91628ac9966b082c596efb46afa /tests/CMakeLists.txt
parent60c0865c6af16c91244123fe6f2c328f5fc912a4 (diff)
Meta type minimal signature should place reference symbol after pointer symbols.
The minimalSignature method was placing '&' before '*'. For example, the signature "foo(Bar*&)" was becoming "foo(Bar&*)". An unit test was added to verify AbstractMetaType::minimalSignature(). Reviewed by Hugo Parente <hugo.lima@openbossa.org> Reviewed by Anderson Lizardo <anderson.lizardo@openbossa.org>
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index 10cce3fc7..61f40ce2e 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -20,6 +20,7 @@ declare_test(testmodifydocumentation)
declare_test(testmodifyfunction)
declare_test(testmultipleinheritance)
declare_test(testrefcounttag)
+declare_test(testreferencetopointer)
declare_test(testremoveimplconv)
declare_test(testreverseoperators)
declare_test(testtoposort)