aboutsummaryrefslogtreecommitdiffstats
path: root/tests/libminimal/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2011-05-16 12:57:58 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:15:23 -0300
commit973a5389ac0f2a5d899025843b9af9e587eff7d3 (patch)
tree7c2988fd044ef091c56d92683a15f145ce99cd0e /tests/libminimal/CMakeLists.txt
parent510e7af9a0e9a8b8c0b90ad76453d9ccdf55aedb (diff)
Added a new test binding called 'minimal'.
The purpose is to have the smallest possible binding to help when doing complex changes that require a good deal of debugging and tracking, and the many operations performed in too many wrapped classes will clutter any output used for those purposes. In other words: don't add anything here except with a good reason for it, prefer to use 'sample' or 'other' binding for that. Reviewed by Hugo Parente <hugo.lima@openbossa.org> Reviewed by Luciano Wolf <luciano.wolf@openbossa.org>
Diffstat (limited to 'tests/libminimal/CMakeLists.txt')
-rw-r--r--tests/libminimal/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/libminimal/CMakeLists.txt b/tests/libminimal/CMakeLists.txt
new file mode 100644
index 000000000..7fa87dc39
--- /dev/null
+++ b/tests/libminimal/CMakeLists.txt
@@ -0,0 +1,11 @@
+project(libminimal)
+
+set(libminimal_SRC
+obj.cpp
+)
+
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+add_definitions("-DLIBMINIMAL_BUILD")
+add_library(libminimal SHARED ${libminimal_SRC})
+set_property(TARGET libminimal PROPERTY PREFIX "")
+