aboutsummaryrefslogtreecommitdiffstats
path: root/tests/libother/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Parente Lima <hugo.pl@gmail.com>2010-08-30 11:19:22 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2010-08-30 17:44:16 -0300
commit1eda671a34eba38e7e74e592e4ae88fa6803bcba (patch)
treea7abd551d478f100579067b948e1a17103aedcfb /tests/libother/CMakeLists.txt
parent3dc673c7bcbad1613b9d3d6ff3dd4a73be41915d (diff)
Fix the type resolver algorithm.
The new algorithm do the following: - Try to use type_info on the object the get the object real name. - Try to find a type resolver with the name returned by type_info. - If a type resolver was found, get the python type. - Else, ask binding manager to resolve the type walking on all possible subclasses found in the inheritance tree. The binding manager has a graph representing the class inheritance tree. Note: This commit break the libshiboken ABI, but not the API. Reviewer: Luciano Wolf <luciano.wolf@openbossa.org> Renato Araújo <renato.araujo@openbossa.org>
Diffstat (limited to 'tests/libother/CMakeLists.txt')
-rw-r--r--tests/libother/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/libother/CMakeLists.txt b/tests/libother/CMakeLists.txt
index 96ab6cab5..9b3cf5552 100644
--- a/tests/libother/CMakeLists.txt
+++ b/tests/libother/CMakeLists.txt
@@ -4,6 +4,7 @@ set(libother_SRC
number.cpp
otherderived.cpp
otherobjecttype.cpp
+othermultiplederived.cpp
)
add_definitions("-DLIBOTHER_BUILD")