aboutsummaryrefslogtreecommitdiffstats
path: root/tests/libsample/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2011-03-29 17:26:57 -0300
committerHugo Parente Lima <hugo.pl@gmail.com>2012-03-08 16:15:19 -0300
commitc5fd9d9dbb33bc4ddbf68315d6b15dc274f076cd (patch)
tree7795da56d99a417d6ec3cc087e8a3eeaae43b1da /tests/libsample/CMakeLists.txt
parent7c35c7788ab02d2d77cbc022d6cf181e7542d995 (diff)
Tests for reverse operators
CPython calls nb_and with swapped arguments for reverse operators. This tests checks if the reverse operator raises NotImplementedError instead of TypeError when there isn't a valid reverse operator. Raising TypeError would cause the operator to fail.
Diffstat (limited to 'tests/libsample/CMakeLists.txt')
-rw-r--r--tests/libsample/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/libsample/CMakeLists.txt b/tests/libsample/CMakeLists.txt
index e1abe6a9b..b2ac420ce 100644
--- a/tests/libsample/CMakeLists.txt
+++ b/tests/libsample/CMakeLists.txt
@@ -37,6 +37,7 @@ str.cpp
strlist.cpp
virtualmethods.cpp
expression.cpp
+filter.cpp
)
include_directories(${CMAKE_CURRENT_SOURCE_DIR})