aboutsummaryrefslogtreecommitdiffstats
path: root/tests/libsample/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2009-12-07 18:59:20 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-12-07 19:07:20 -0300
commitdc1ca0f9a9aa216973a6ab1f458f0f965033530d (patch)
treee53b57daeb418acc1f3e70db3378443aee9d26b2 /tests/libsample/CMakeLists.txt
parentcd830d9435ab10c7961bc4d73644c9532495ce80 (diff)
Adds StrList test to check classes that inherit from containers.
StrList class inherits from std::list<Str> and expand it with a couple of methods. The added tests perform many different comparisons using other StrList objects, Python sequences of Str objects, and Python sequences of Python strings.
Diffstat (limited to 'tests/libsample/CMakeLists.txt')
-rw-r--r--tests/libsample/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/libsample/CMakeLists.txt b/tests/libsample/CMakeLists.txt
index 8d4a890d5..8dd38fa3a 100644
--- a/tests/libsample/CMakeLists.txt
+++ b/tests/libsample/CMakeLists.txt
@@ -28,6 +28,7 @@ simplefile.cpp
size.cpp
sometime.cpp
str.cpp
+strlist.cpp
virtualmethods.cpp
)