aboutsummaryrefslogtreecommitdiffstats
path: root/tests/samplebinding/CMakeLists.txt
diff options
context:
space:
mode:
authorHugo Lima <hugo.lima@openbossa.org>2009-08-31 19:39:09 -0300
committerHugo Lima <hugo.lima@openbossa.org>2009-08-31 19:42:53 -0300
commit1eef8c3c7c905675ddeb09e7ada3e98e8b6fa4b5 (patch)
tree48fe5608bd68d25ec003aaa1d03ddf8be9c4c05e /tests/samplebinding/CMakeLists.txt
parente853413dc073d187ccc0a5d5c252332b4f5e37c1 (diff)
Added a corner case to broke Shiboken tests >:-)
Shiboken generates wrong C++ code when exists a function/method that returns a type without a default constructor.
Diffstat (limited to 'tests/samplebinding/CMakeLists.txt')
-rw-r--r--tests/samplebinding/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/samplebinding/CMakeLists.txt b/tests/samplebinding/CMakeLists.txt
index 67ca34313..cc509d772 100644
--- a/tests/samplebinding/CMakeLists.txt
+++ b/tests/samplebinding/CMakeLists.txt
@@ -12,6 +12,7 @@ ${CMAKE_CURRENT_BINARY_DIR}/sample/implicitconv_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/listuser_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/modifications_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/mapuser_wrapper.cpp
+${CMAKE_CURRENT_BINARY_DIR}/sample/nondefaultctor_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/pairuser_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/point_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/reference_wrapper.cpp