aboutsummaryrefslogtreecommitdiffstats
path: root/tests/samplebinding/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2010-01-28 15:53:40 -0300
committerHugo Lima <hugo.lima@openbossa.org>2010-01-28 19:04:58 -0200
commit6daffa0a3452ee36ca8c39cf90fb0cefcbb5c205 (patch)
tree12faa27dcb6251f9b5ddd9b5ad458c66b371cc96 /tests/samplebinding/CMakeLists.txt
parent22eb430cecf6ddc10eed04dd67c81485aba84ab6 (diff)
Adds support for void pointer conversions.
A new converter specialization was added to deal with 'void*' conversions. In the case of C++ generating a unknown void pointer a BaseWrapper is used to hold the said pointer. There is a new test for this situation. Reviewed by Renato Araújo <renato.filho@openbossa.org>
Diffstat (limited to 'tests/samplebinding/CMakeLists.txt')
-rw-r--r--tests/samplebinding/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/samplebinding/CMakeLists.txt b/tests/samplebinding/CMakeLists.txt
index 59996a555..de24c02fe 100644
--- a/tests/samplebinding/CMakeLists.txt
+++ b/tests/samplebinding/CMakeLists.txt
@@ -61,6 +61,7 @@ ${CMAKE_CURRENT_BINARY_DIR}/sample/time_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/virtualdaughter_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/virtualdtor_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/virtualmethods_wrapper.cpp
+${CMAKE_CURRENT_BINARY_DIR}/sample/voidholder_wrapper.cpp
)
find_program(GENERATOR generatorrunner REQUIRED)