aboutsummaryrefslogtreecommitdiffstats
path: root/tests/samplebinding/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2009-09-01 22:34:00 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-09-01 23:05:50 -0300
commitc5f22026676c907eb91442754a7d4cfe0486f045 (patch)
tree0a152f8c88444387038a8fbe3af72dec8fec7323 /tests/samplebinding/CMakeLists.txt
parent06ebb031b31d1c37eb7f2888d38356a2f083cd81 (diff)
Changed generator to convert the method call results on wrapped methods
at each possible call, instead of receiving the return value in the C++ type and converting it later. Having the result value as a PyObject pointer avoids the problem of declaring the return value variable with a class that do not have a simple constructor. Example: "Foo resultValue;" is a problem when the only constructor for "Foo" is "Foo(int)". The above described problem is made worse with the addition of OddBool and OddBoolUser cases to the sample library. OddBool is registered as a primitive (and convertible) type, registered this way it is only available as a TypeEntry and a suitable constructor cannot possibly be found. This is different from Value and Object types for they become AbstractMetaClass objects and all constructor signatures can be queried.
Diffstat (limited to 'tests/samplebinding/CMakeLists.txt')
-rw-r--r--tests/samplebinding/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/samplebinding/CMakeLists.txt b/tests/samplebinding/CMakeLists.txt
index 0486ec925..3d80ff9c0 100644
--- a/tests/samplebinding/CMakeLists.txt
+++ b/tests/samplebinding/CMakeLists.txt
@@ -13,6 +13,7 @@ ${CMAKE_CURRENT_BINARY_DIR}/sample/listuser_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/modifications_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/mapuser_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/nondefaultctor_wrapper.cpp
+${CMAKE_CURRENT_BINARY_DIR}/sample/oddbooluser_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/pairuser_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/point_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/privatedtor_wrapper.cpp