aboutsummaryrefslogtreecommitdiffstats
path: root/tests/samplebinding/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2009-11-17 16:20:43 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-11-18 08:47:46 -0300
commit515d3e34046415007027a1749a7a3be2a8b7a534 (patch)
tree601160d7c800345bf2d62161e95b727fa7e4ad7f /tests/samplebinding/CMakeLists.txt
parent5a579efa850071ef06345a982611eb19995f8187 (diff)
Added support for the type system "invalidate-after-use" argument modification.
The Python wrapper object produced for an argument received from C++ on a virtual method call is marked as invalid after the call to the Python override. If the Python script keeps the wrapper and try to use it afterwards a RuntimeError exception is raised. Test cases were added using the ObjectType::event method and the new Event class.
Diffstat (limited to 'tests/samplebinding/CMakeLists.txt')
-rw-r--r--tests/samplebinding/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/samplebinding/CMakeLists.txt b/tests/samplebinding/CMakeLists.txt
index 7e946d5b2..af73a6bdb 100644
--- a/tests/samplebinding/CMakeLists.txt
+++ b/tests/samplebinding/CMakeLists.txt
@@ -10,6 +10,7 @@ ${CMAKE_CURRENT_BINARY_DIR}/sample/abstract_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/collector_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/derived_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/echo_wrapper.cpp
+${CMAKE_CURRENT_BINARY_DIR}/sample/event_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/implicitconv_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/intwrapper_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/injectcode_wrapper.cpp