aboutsummaryrefslogtreecommitdiffstats
path: root/tests/samplebinding/CMakeLists.txt
diff options
context:
space:
mode:
authorLauro Neto <lauro.neto@openbossa.org>2010-01-15 15:39:41 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2010-01-15 20:12:25 -0300
commit72ca828dde351cc3b715eec5447fe4ea5c46ec01 (patch)
treee8cc0a754e3953fd629c432b9ac44eac22f7a8b5 /tests/samplebinding/CMakeLists.txt
parent007d8cf6955f0f99a41bad8c69c9da7789d6bbe8 (diff)
Adding new tests related to threads/GIL locking
- Event loop - calling virtual methods from C++ - Event loop with thread - calling virtuals from C++ along with accessing the binding from another python thread - Thread locking - blocker C++ method that is unlocked from another python thread For these tests, a new ObjectType subclass was added, Bucket, which is just a container for the producer/consumer tests and has the lock/unlock method. Reviewed by Marcelo Lira <marcelo.lira@openbossa.org>
Diffstat (limited to 'tests/samplebinding/CMakeLists.txt')
-rw-r--r--tests/samplebinding/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/samplebinding/CMakeLists.txt b/tests/samplebinding/CMakeLists.txt
index fee52d267..fed9519a3 100644
--- a/tests/samplebinding/CMakeLists.txt
+++ b/tests/samplebinding/CMakeLists.txt
@@ -14,6 +14,7 @@ ${CMAKE_CURRENT_BINARY_DIR}/sample/base4_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/base5_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/base6_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/blackbox_wrapper.cpp
+${CMAKE_CURRENT_BINARY_DIR}/sample/bucket_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/collector_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/derived_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/echo_wrapper.cpp