aboutsummaryrefslogtreecommitdiffstats
path: root/tests/samplebinding/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcelo Lira <marcelo.lira@openbossa.org>2009-10-20 15:34:18 -0300
committerMarcelo Lira <marcelo.lira@openbossa.org>2009-10-20 15:34:18 -0300
commita1ea10151397cefd86aa0f6c4822932d2cc6a601 (patch)
tree72a43ad326839a1c56217b893f999c28ad0c30f3 /tests/samplebinding/CMakeLists.txt
parent0953187f7b13b8ca410c8db8fa856154cc6729a8 (diff)
added the SimpleFile class to the sample library to check how a
method returning a boolean value that indicates success/failure on a IO operation could be modified to express the any occurring problems as Python exceptions (in this case IOError); the generator was changed to return a 'None' value for Python callers on methods that had it's return value removed
Diffstat (limited to 'tests/samplebinding/CMakeLists.txt')
-rw-r--r--tests/samplebinding/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/samplebinding/CMakeLists.txt b/tests/samplebinding/CMakeLists.txt
index fc2a47b92..4e53c84a1 100644
--- a/tests/samplebinding/CMakeLists.txt
+++ b/tests/samplebinding/CMakeLists.txt
@@ -23,6 +23,7 @@ ${CMAKE_CURRENT_BINARY_DIR}/sample/privatedtor_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/reference_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/sample_module_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/samplenamespace_wrapper.cpp
+${CMAKE_CURRENT_BINARY_DIR}/sample/simplefile_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/size_wrapper.cpp
${CMAKE_CURRENT_BINARY_DIR}/sample/virtualmethods_wrapper.cpp
)